1997 Mercury Cougar - Mercury Forum - Mercury Enthusiasts Forums

Go Back   Mercury Forum - Mercury Enthusiasts Forums > Past Productions > Cougar
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-16-2011, 07:36 PM
Junior Member
 
Join Date: Jan 2011
Posts: 1
Default 1997 Mercury Cougar

i own a 1997 Mercury Cougar XR7 4.6 v-8 i have changed plugs, plug wires, crank position sensor, camshaft position sensor. i have checked fuel pressure, coil packs. i am still having cranking issues, it might crank with one turn of the key,it might decide to just spin. does anyone have a remedy other than a bonfire, or boat anchor?
Reply With Quote
 
 
 
Reply

Tags
1997, 97, angle, camshaft, connector, cougar, crank, crankshaft, forum, location, mercury, position, sensor, sensore, xr7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 Mercury Cougar XR7 Michael New Member Area 3 09-15-2009 11:34 AM
1997 Mercury Villager Nautica brusch Detailing 2 01-18-2008 08:44 PM
code p0172 and p1443 on 1997 cougar hardhittincapri Cougar 0 09-26-2007 05:00 PM
1997 xr-7 cougar 3.8 to 5.0 swap neverstopsaul Cougar 1 05-12-2006 12:35 PM
1997 Mercury Grand Marquis poor fuel econ salvatore Grand Marquis 11 01-10-2005 04:18 PM

Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 07:44 AM.