Problems with my 2000 Grand Marquis LS - Mercury Forum - Mercury Enthusiasts Forums

Go Back   Mercury Forum - Mercury Enthusiasts Forums > Vehicle Line Up > Grand Marquis

LinkBack Thread Tools Search this Thread
Old 08-24-2012, 10:39 AM
Junior Member
Join Date: Aug 2012
Posts: 2
Exclamation Problems with my 2000 Grand Marquis LS

Hi everyone my name is Gil and I'm new to the forum.

I hope I can get some help from you guys because I've been having a few problems with my baby (Grand Marquis)

First the engine was running very bad after cleaning it with water, we then had to change an ignition coil and she was back running great. One week later the same thing happened (without washing the engine) and
I don't know if it's the coil again .. It runs very bad like at 40% not even, it smells like gas really bad and I'm lost .. It's been parked since then!

Second, the fan only works one time out of ten.. I have absolutly no idea what might be the problem!

Last but not least, there is one fuse that keeps breaking, it is the one for the blinkers and the climate control. Could it be related to the fan not working? I don't know.

Any help would be appreciated thanks alot guys

Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 Grand Marquis LS-having ac problems-can anybody help? jandmongodsteam General Tech Help 2 04-24-2011 10:44 AM
2008 Grand Marquis LS-having ac problems/HELP jandmongodsteam Grand Marquis 2 04-11-2011 09:51 PM
Electric problems on Grand Marquis Roby Grand Marquis 2 03-02-2011 06:24 AM
95 Grand Marquis Transmission Problems!!! serendipity736 Grand Marquis 6 11-04-2008 05:43 PM
1994 Grand Marquis Engine Problems mgmswanga Grand Marquis 1 08-26-2007 01:52 AM

2000, coil, engine, fan, gm, grand, ignition, inside, jumping, ls, marquis, merc, prob, rad, stopped, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -5. The time now is 05:59 PM.