Go Back   Mercury Forum - Mercury Enthusiasts Forums > Past Productions > Cougar
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-09-2012, 10:29 AM
Drguru79 Drguru79 is offline
Junior Member
 
Join Date: Dec 2012
Posts: 1
Default 1999 Mercury Cougar won't start

Thursday morning I cranked the engine and it immediately died. Cranked it again and died. Cranked it again and gave it some gas. Drove to school and back (about 3 or 4 miles) with no issues. Saturday afternoon I cranked the engine and it did the same thing - cranks and died. Cranked it again now this time only clicks. I gave it some time to rest. This time when Iry to crank it, it turns over slowly and then only clicks. The headlights, radio, and power windows all work as normal. Cleaned the battery cable connections but this made no difference.
The clicking and no start happened once before a couple of weeks ago but I was able to pop the clutch to get it going and have had no other issues until now. I went to autozone to check the alternator and battery but they checked out. Any thoughts? I want to say the starter but why would the engine start and die immediately? The fuel pump sounds like it is turning on when I turn the ignition on.
Reply With Quote
Old 12-09-2012, 10:29 AM
 
 
 
Reply

Tags
1999, 99, alarm, cougar, cranks, died, forum, light, mercury, point, reasons, star, start, turn, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 04:51 PM.

Internet Brands, Inc.