Monterey Discuss the Mercury Monterey here...

1962 Mercury Monterey project

  #1  
Old 03-29-2008, 04:33 PM
Junior Member
Thread Starter
Join Date: Mar 2008
Location: United States
Posts: 12
Default




Got one on the way..Will post up pics soon..I posted these questions in my intro though


1:Is the '62 Galaxie roofline the same as the 2 door '62 Mercuy Monterey Hardtop?


2:Is the 352 in my Mercury the same as the Ford truck 352's??
 
  #2  
Old 03-30-2008, 01:03 PM
Junior Member
Thread Starter
Join Date: Mar 2008
Location: United States
Posts: 12
Default




Name:  010106010309010410200709251fd232658.jpg
Views: 17
Size:  14.0 KB


Name:  0101080104000103102007092542c01e53f.jpg
Views: 17
Size:  14.0 KB


Name:  cartrailer3.jpg
Views: 18
Size:  14.0 KB


Name:  Image1401.jpg
Views: 18
Size:  14.0 KB
 
  #3  
Old 03-30-2008, 01:05 PM
Junior Member
Thread Starter
Join Date: Mar 2008
Location: United States
Posts: 12
Default




Name:  Image1451.jpg
Views: 16
Size:  14.0 KB


Name:  Image1491.jpg
Views: 19
Size:  14.0 KB


Name:  untitledsed.jpg
Views: 17
Size:  14.0 KB


Name:  Image1511.jpg
Views: 17
Size:  14.0 KB
 
  #4  
Old 03-30-2008, 01:06 PM
Junior Member
Thread Starter
Join Date: Mar 2008
Location: United States
Posts: 12
Default





Name:  Photo-04961.jpg
Views: 19
Size:  14.0 KB


Name:  Image1531.jpg
Views: 17
Size:  14.0 KB


Name:  Motor2.jpg
Views: 17
Size:  14.0 KB


Name:  sdwww.jpg
Views: 18
Size:  14.0 KB
 
  #5  
Old 03-31-2008, 08:56 AM
Senior Member
Join Date: Nov 2007
Location:
Posts: 179
Default



nice old ride bro. those older ford rooflines look like that, idk the same exact or not? I think the engines are the same, that 352 wouldn't be a different one.


When you get it fixed up, that thing will be a real show stopper[img]smileys/smiley1.gif[/img]
 
  #6  
Old 04-07-2008, 05:32 AM
Junior Member
Thread Starter
Join Date: Mar 2008
Location: United States
Posts: 12
Default

I just got it home yesterday.She has a few rot spots that I didn't find out about until she got here,but they are all small.She does fire up first try though!!!Not too major of a project..Need to get the brakes checked though,feels like I'm stepping on a brick and the car almost doesn't stop..Feels like they need to be bled..
 
  #7  
Old 04-07-2008, 09:32 AM
Senior Member
Join Date: Nov 2007
Location:
Posts: 179
Default



Originally Posted by MattMonterey
Need to get the brakes checked though,feels like I'm stepping on a brick and the car almost doesn't stop..Feels like they need to be bled..
hahah You may have to wear combat boots to slam those brakes...no ABS like new cars, bet there's a huge difference there, plus those things don't they have just like drum brakes and no disc?
 
  #8  
Old 04-07-2008, 01:44 PM
Junior Member
Thread Starter
Join Date: Mar 2008
Location: United States
Posts: 12
Default

Originally Posted by 20marquis07


Originally Posted by MattMonterey
Need to get the brakes checked though,feels like I'm stepping on a brick and the car almost doesn't stop..Feels like they need to be bled..
hahah You may have to wear combat boots to slam those brakes...no ABS like new cars, bet there's a huge difference there, plus those things don't they have just like drum brakes and no disc?




They are drum,but they are power drums...
 
  #9  
Old 04-07-2008, 05:37 PM
Senior Member
Join Date: Nov 2007
Location:
Posts: 179
Default

Originally Posted by MattMonterey
Originally Posted by 20marquis07


Originally Posted by MattMonterey
Need to get the brakes checked though,feels like I'm stepping on a brick and the car almost doesn't stop..Feels like they need to be bled..
hahah You may have to wear combat boots to slam those brakes...no ABS like new cars, bet there's a huge difference there, plus those things don't they have just like drum brakes and no disc?

They are drum,but they are power drums...

I've drove disc front drum rear power but not drum all around. Thoes still stop different i know...lol
 
  #10  
Old 05-08-2008, 06:57 AM
Junior Member
Thread Starter
Join Date: Mar 2008
Location: United States
Posts: 12
Default


Now I have an electrical problem with the headlights...When the high beam is off,all four lights want to come on,but one is out,when i hit the footswitch to put it to highbeam,only the two on the drivers side come on(and the one that doesn't come on when all four want to work while the low beams are on is on the drivers side)...Any help??
 

Thread Tools
Search this Thread
Quick Reply: 1962 Mercury Monterey project


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.