Mystique Discuss the Mercury Mystique here...

Mystique Forum: where is everyone?

  #1  
Old 07-28-2007, 02:22 PM
Junior Member
Thread Starter
Join Date: Jul 2007
Location: United States
Posts: 2
Default



With all the problems people have, Im suprised there is no more people on this forum.


NEway, I have a 96 LS mystique V6 AT w/75k miles. My check engine light is always on, and the code is for the EGR valve. Ive had the valve and EGR sensor replaced, but no luck after clearing the codes. I also had mass airflo sensor replaced, O2 sensors, and water pump. The radiator fan seems to run loud after the engine temp gets to normal. Now there is a humming noise coming from under the hood. Im gonna have to check the tensioners and belts to see if anything is wrong. This is a fantastic car, power, very comfortable. I hopemy baby will last long enough to be considered a classic
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
apple2005
Grand Marquis
2
03-02-2009 02:25 PM
1FaSTLsE
New Member Area
2
12-06-2005 01:37 PM
thrackley
Mariner
6
09-11-2005 05:37 PM
MercAdvisor
Off Topic
0
01-02-2005 04:47 PM
MercAdvisor
New Member Area
2
11-06-2004 09:50 AM


Thread Tools
Search this Thread
Quick Reply: Mystique Forum: where is everyone?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.