Audio/Visual Electronics Wired up? Everyone's got some sort of electrical modification... let's hear about it here...

88 grand marquis premium sound

  #1  
Old 06-23-2011, 09:21 PM
Junior Member
Thread Starter
Join Date: Jun 2011
Posts: 5
Default 88 grand marquis premium sound

Hello all just purchased a 1988 grand marquis ls with 82000 original miles on it yesterday and it is mint other than one problem. On my 10 or so mile test drive the radio worked fine, but when i left to take it home i turned the radio on and it worked fine for about 30 secs. At which point i heard a light static pop and all sound stopped the radio still turns on and changes stations. But if you scan for a station it never stops almost as if it cant find anything and whether you use the tuner or cassette there is no sound coming from the speakers other than a slight crackle every now and then. I have no clue wht could have possibly happened the car does have the premium audio system with the amplifier in the trunk and everything looks fine i had the radio out of the dash and all connections were tight but still nothing. Im at a loss for what to do as i would really prefer not to drive around without ever having a radio. The only thought ive had is to take it to a local car audio place and have them install a halfway decent cd player and bypass the factory amp if needed. So im hoping someone out there has some experience with this and can tell me if i should take the time and money to have it fixed correctly or do whatever i can id rather not sink more than say $350-$400 max in the whole project. Thanks in advance for any helpful advice anyone may have as this is an exceedingly frustrating predicament for me.
 
  #2  
Old 06-26-2011, 01:04 PM
Junior Member
Thread Starter
Join Date: Jun 2011
Posts: 5
Default fixed

Ok got it figured out it just so happens that the factory amp blew so I got a bypass adapter from bestbuy and installed my sony cd player and voila all six speakers are working and it has amazing sound quality for being 23 years old
 
  #3  
Old 08-26-2011, 10:26 PM
Junior Member
Join Date: Aug 2011
Posts: 4
Default

I would like more information about the "bypass" you got.. I have a 88 Colony Park with the 6 speaker Premium System. I was going to install an aftermarker HU today, when I ran into wiring issues.......
 
  #4  
Old 10-31-2012, 08:19 AM
Junior Member
Join Date: Oct 2012
Location: http://www.dvdsetsbest.co.uk/
Posts: 3
Default

A custom auto stereo shop could get it done, but it's going to be a pretty penny.
 
  #5  
Old 11-05-2012, 03:18 PM
Junior Member
Join Date: Aug 2011
Posts: 4
Default

Holy old thread revival..

It wasnt too difficult to install an aftermarket HU w/ 6 speakers. 6ch amp and split leads for front channels.

Alpine Type-R 4" in Dash, 5-1/2" in Doors and 6x9 in Rear.

The wiring in the car was so brittle, I needed to rerun speaker wire anyways.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
batrot
Grand Marquis
0
08-11-2015 07:29 PM
peteb5
Grand Marquis
0
06-06-2012 09:03 PM
furt0414
Sable
2
05-24-2009 04:31 PM
Faze311
Milan
2
12-29-2008 02:37 PM
digdug
Sable
5
02-22-2008 01:08 PM


Thread Tools
Search this Thread
Quick Reply: 88 grand marquis premium sound


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.