Cougar Discuss all years of the Mercury Cougar here...

Wipers on the Fritz!!

  #1  
Old 01-12-2012, 07:26 PM
Junior Member
Thread Starter
Join Date: Jan 2012
Posts: 3
Default Wipers on the Fritz!!

My wipers will act up once in a while and Im concerned because at the same time all my lights dim for a second like my battery goes dead, but only for a second and the wipers keep moving like an inch every 2 seconds and this goes on and on and on. the wipers do the normal up and down just SUPER slowly. Like I said they move an inch or two every couple seconds The guy that owned the car before me apparently put some kind of strobes in with the headlights and Im worried that this may be the problem like maybe I have an electrical short or something...I bought it from a dealership though so those things should have been checked out. I am a girl.....I dont know much about cars so please try and keep the terms to a level to where I can understand lol!! Thanks in advance!
Emily
 
  #2  
Old 01-16-2012, 08:18 PM
Junior Member
Join Date: Jan 2012
Posts: 11
Default

Emily,
I sort of doubt the strobes or whatever the previous owner did to the headlights has anything to do with the wiper circuit. It sounds like your wiper motor is going bad causing the wipers to move slow and draw excessive power. You didn't mention how long ago you purchased it from a dealer, but if recently I would take it back to them and see if they can help you.
 
  #3  
Old 01-19-2012, 09:45 AM
Junior Member
Thread Starter
Join Date: Jan 2012
Posts: 3
Default I think I may have found the problem

So I replaced my wiper motor and it still doesn't work. Now Im spending another hundred dollars or so getting a new switch for inside the car. Hope this works.. The funny part is, I was sure it was the motor so I got rid of my receipt for the new one so I couldn't take it back even if I wanted to. although the old motor was factory so it probably didn't hurt. But the switch was valued at 240 bucks because ford doesn't make it anymore and its a pain in the a$$ to find. I just think the dealership that sold me my car should have checked a lot of things out before they put the car up for sale. A lot of things were broken and rigged. I probably should have been a more knowledgeable buyer too but hey, what can you do?
 

Last edited by emyq; 01-19-2012 at 09:50 AM.
  #4  
Old 01-20-2012, 03:20 PM
Junior Member
Join Date: Jan 2012
Posts: 11
Default

Hi Emily,
Its a shame you don't have someone to properly diagnose your problem before you go broke parts swapping. You never said what year, make & model your car was so we don't know the exact configuration of your wiper circuit or whether your car has a wiper control module or relay.
 
  #5  
Old 01-23-2012, 12:28 PM
Junior Member
Thread Starter
Join Date: Jan 2012
Posts: 3
Default this is getting so rediculous its funny!!

So I replaced the switch....NOTHING!! ha-ha! I'm having the fuses rechecked and also having a licensed mechanic test to see if there is a bare wire or short somewhere. it just keeps gettin better and better, doesn't it? by the way its a 2000 Mercury Cougar V6 with wipers in front and also the back window
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Wipers123
General Tech Help
1
03-28-2009 12:08 AM
96mercurygm
Grand Marquis
15
03-24-2008 11:23 PM
daniele
Grand Marquis
3
06-08-2007 07:18 AM
TerryA
Sable
1
07-12-2006 01:08 PM
JoeB
Grand Marquis
6
04-19-2006 10:10 PM


Thread Tools
Search this Thread
Quick Reply: Wipers on the Fritz!!


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.