General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

2006 Mariner tail light problem

  #1  
Old 01-07-2014, 01:58 PM
Junior Member
Thread Starter
Join Date: Jan 2014
Posts: 1
Default 2006 Mariner tail light problem

I have a 2006 Mariner that has a weird left taillight problem. When the lights are on, the large filament (left side) glows as the tailight, rendering the turn signal inoperable. L turn sig works fine with lights off.When lights are on, L turn sig flashes twice as fast as normal. Also, (lights off) when stepping on rhe brake, the left front park light comes on. Tried new bulb-no fix. Cleaned and tightened ground wires to chassis-no help. Small filament seems to get no voltage, though socket shows short when connected to chassis wiring. According to the wiring diagram, everything else run by the park light circuit works fine. Any help on this would be greatly appreciated!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MellowSoul
Sable
0
02-11-2011 01:33 PM
deloreandude86
Mountaineer
0
01-26-2011 05:11 PM
love2puck14
Mountaineer
0
05-22-2009 03:02 PM
nikoh
Monterey
0
06-17-2008 05:30 PM
luvmymarinerd
Mariner
0
08-30-2006 09:57 PM


Thread Tools
Search this Thread
Quick Reply: 2006 Mariner tail light problem


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.