General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

74 xr7 tuning problems

  #1  
Old 05-12-2010, 11:31 AM
Junior Member
Thread Starter
Join Date: May 2010
Posts: 2
Default 74 xr7 tuning problems

well to start off, good afternoon. the car: 1974 xr7. engine: 1971 302, standard bore and stroke. performer rpm heads, performer 289 intake, 750 holly dual feed carb, crane cam and lifter set, noisy gear timing set, 1.6 roller rocker and tall valve covers. so i guess it would be mildly modified? anyway now to the problem: the intake was the last installed part and all went well. set the timing to 6deg adv. to start and set the carb back to stock settings. but the issue is i have throttle response at idle(550rpm) in park, the engine hickups around 1100rpm then runs correct past 1200rpm. in drive idle rpm is around 500 but has absolutly 0 power, throttle response or brakes. what could be the cause i dont have enough experience in dealing with this to trouble shoot. any help would be better than what i have now thanks.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Tom6687
Engine & Internal
1
08-17-2011 07:08 PM
ERNurse
New Member Area
3
08-10-2011 05:06 AM
wietse
Cougar
19
03-10-2009 06:14 PM
void42
Cougar
0
07-17-2006 02:39 AM
COUGARNUT
Cougar
10
04-22-2006 03:09 AM


Thread Tools
Search this Thread
Quick Reply: 74 xr7 tuning problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.