General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

New Member Need Electrical Help 1962 Merc Monterey

  #1  
Old 09-01-2012, 07:42 PM
Junior Member
Thread Starter
Join Date: Sep 2012
Posts: 6
Default New Member Need Electrical Help 1962 Merc Monterey

I wasn't sure if I should post this here or in the MM section. Here goes. I hope you guys or gals can help.

So I have a '62 Merc Monterey, was driving my daughter to University today about an hour away from home and about half way there I notice my blinkers aren't working, no horn, zero electrical. Car is running good though so I kept pushing on. I get to the school and unload, head out to go home and the car won't start. Got a boost and it started (difficult but it did roll over after about 10 minutes of charging). Heading home all blinkers and horn and other accessories are working until about 20 minutes into the drive and then again everything dies out.

The car ran fine again and got me home, but when I shut if off and tried to restart, nothing. just faint clicking. Last year I replaced the battery, and also the wires going from the solenoid to the battery, and battery to the block. (Neutral). My question is this, could my alternator be shot? The wires going off the solenoid to down to the alternator split off and some go to the starter while the other two? go to the alternator they seem brittle. Problem is I can't find a harness anywhere that I can use to replace.

Any advice would be greatly appreciated.

C
 
  #2  
Old 09-01-2012, 07:44 PM
Junior Member
Thread Starter
Join Date: Sep 2012
Posts: 6
Default

Oh I should add, I went to Part Source and the guy sold me two cables and said to wire direct to the starter with one, and direct to the alternator with the other. Problem is the alternator has two really small wires that go to the top, the cable he sold me has two open ring style cables. (Actually they are the same style cables I used last year when I replaced the battery.)
 
  #3  
Old 09-02-2012, 10:39 PM
Junior Member
Thread Starter
Join Date: Sep 2012
Posts: 6
Default

over 24 hours no answer? Terrible forum. Moving elsewhere./
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RailRider
New Member Area
1
06-03-2015 03:57 AM
straycat60
Monterey
7
03-11-2013 11:21 AM
jswift
Monterey
0
12-09-2010 09:37 AM
finewhineperf
Monterey
4
07-27-2009 08:43 AM
OneBadV8
Monterey
1
07-26-2009 08:42 AM


Thread Tools
Search this Thread
Quick Reply: New Member Need Electrical Help 1962 Merc Monterey


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.