Sable Discuss the Mercury Sable here...

No heat, yet again, no answers here so far

  #1  
Old 10-19-2013, 02:43 PM
Junior Member
Thread Starter
Join Date: Oct 2013
Posts: 1
Default No heat, yet again, no answers here so far

Hi all,

My 98 sable had no heat. I brought it back to the mechanic i bought it from. He did a full coolant flush, and flushed the heater core! Heat was so hot, I could barely keep it on...THEN!

The next day, my upper radiator hose sprung a leak and my coolant ran out slow at first, then faster.

I replaced the upper radiator hose, and now, no heat again! $240 to be back at square one.

Any idea why after I replaced the hose, the heat died? Bubble in the system? Tried to run it with cap off reservoir, and tried to bleed out the air by squeezing the upper radiator hose. All hoses get hot. possible air blockage? if so, how do i get ti out. Makes no sense why the heat quit afterwards, and my mechanic decided not to return my calls....any help would be appreciated, its starting to get cold out and im absolutely broke!!
 
  #2  
Old 03-14-2014, 05:29 AM
Junior Member
Join Date: Mar 2014
Posts: 3
Default

if mechanic is not returning your calls find a new one. That being said not sure what year your sable is like 95 to 99 I have a 97 the heating system in these cars are the worst I have ever seen. once you think you have it something else goes wrong. finally had mine fixed. it was the dreaded water pump course with the nasty rust that happens in these had to replace the heater core as well. But if it was working one day then nothing might want to check your Actuator there is a little white box under the dash that opens and closes your Blend door that allows the heat to come though. that might have gone bad only allowing cold air to come though. if you look under the dash there will be a cover that covers this box but if you can see past it or get it off when you turn your heater from cold to hot then back again this should be moving your heater doors open and closed. sorry for the long winded reply.
 
  #3  
Old 07-28-2014, 08:37 PM
Junior Member
Join Date: Jul 2014
Posts: 3
Default

My '02 Sable heater died Dec' 13. My mechanic did the flush thing and several other attempts that cost over $300 and it was a waste of time and $. Took it to a dealer garage and they had the diagnostic equipment, etc. and they got the heat back to 95% . Sables need attention at the 100K miles point, plugs, injectors, heating, transaxle service, etc.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
greggyc
General Tech Help
5
12-30-2008 06:00 AM
88Tracer
Tracer
4
02-07-2008 07:15 AM
92Mercury
Cougar
0
11-22-2007 10:01 AM
Melissa B.
General Tech Help
5
03-13-2006 09:18 PM
Windzer
Sable
12
04-29-2005 09:18 PM


Thread Tools
Search this Thread
Quick Reply: No heat, yet again, no answers here so far


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.