Sable Discuss the Mercury Sable here...

Stalls out

  #1  
Old 03-11-2012, 09:47 PM
Junior Member
Thread Starter
Join Date: Dec 2011
Posts: 5
Default Stalls out

2002 Mercury Sable, 103,000 miles.
this car runs well but every now and then while traveling on the intestate, all but two times, it will buck once or twice and stall out within a couple of seconds. It will start right back up again and work fine. It has happend two or three times a month over the past 4 months.

Thank you in advance.
 
  #2  
Old 04-07-2012, 03:57 PM
Junior Member
Join Date: Apr 2012
Location: Southeast VA
Posts: 8
Default Car is idling rough- P1074 and P1071 codes

My 2000 Sable with 135K miles runs great, except it is rough now on idle, and getting worse.

Engine light is on, codes above were noted.

No vacumn leaks detected.

MAF sensor issue maybe? Or H20S sensor?

I am still new at working on cars, and am trying to diganose this to determine if I need a new MAF sensor or O2 sensor, or something else.

New Fuel pump less then a year ago, and I will be replacing the fuel filter as well (although I replace them about every two years.

Car runs great other than telling me it is rich/lean, and now stalling more when parked or at a light.

Any ideas?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
techgrad03
Mountaineer
3
06-15-2007 12:56 PM
cbhoov1
Sable
4
04-16-2007 11:06 PM
goodmanv
Cougar
0
03-20-2007 01:02 PM
goodmanv
New Member Area
0
03-19-2007 02:23 PM
lkmfcars
Sable
0
01-18-2007 08:48 PM


Thread Tools
Search this Thread
Quick Reply: Stalls out


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.