Villager Discuss the Mercury Villager here...

Injectors

  #1  
Old 10-03-2007, 09:33 AM
Junior Member
Thread Starter
Join Date: Oct 2007
Location: United States
Posts: 1
Default



I had codes of P325 and P305 and whittled it down to an injector problem in cylinder #5. Ohms test showed dead injector. Since I had to remove intake (not a fun job!), I pulled all the other injectors and tested them as well. Results were 11.8, 12.4, 12.4, 12.4, and 17.6 ohms for the other five.


1. Should I replace the 17.6 also?


2. Original injectors do not have a black or blue mark on them but dealer says I must choose one or the other. Does it really matter and, if so, which should I choose?


3. I think I screwed up by not releasing fuel pressure before pulling injectors. I discovered this step in a post too late. What problems could result from this error and what can I do at this point to correct?


Thanks in advance for help with any or all of these questions!





 
  #2  
Old 03-12-2008, 04:06 PM
Junior Member
Join Date: Mar 2008
Location: United States
Posts: 3
Default

What were the symptoms that you experienced before doing the injectors? I
keep having issues with the engine light coming on and flashing but it will
stop again. I'm also getting codes for O2 sensor, knock sensor and misfires
in cyls 1, 3 and 5. Saw that it could be an injector issue, but am not sure
with the sensor codes.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
powerplayer05
General Tech Help
2
06-10-2010 07:26 PM
troppus8
Sable
1
03-23-2007 02:29 AM


Thread Tools
Search this Thread
Quick Reply: Injectors


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.