Cougar Discuss all years of the Mercury Cougar here...

95 cougar no oil pressure...

  #1  
Old 09-02-2009, 11:32 AM
Junior Member
Thread Starter
Join Date: Sep 2009
Posts: 3
Exclamation 95 cougar no oil pressure...

my light in my car is telling me I have no oil, but its full
I jus wanna try to find out if my oil pump is going bad, or its jus the sending unit or possibly jus the gauge is bad!
i'm hopeing for the cheapest possibly...lol...

but is there really any way to tell why the gauge is telling me that?
im jus afraid to drive it, it the pump it not working and the engine isnt gettin any oil.
the motor sounds perfectly fine, itsnt knocking or anything yet...

anyone have ant info....
plz lemme know!
thx!
 
  #2  
Old 09-02-2009, 01:36 PM
Senior Member
Join Date: Oct 2008
Location: United States
Posts: 1,361
Default

try replacing the oil pressure sensor (just below the oil filter on the 4.6. not sure about other engines (haven't looked). Also, check the connection and wire condition. if it's not connected or the wire is broken (which can happen if you happen over some sticks in the road just right) then it'll turn the light on. Replacing the pressure sensor is pretty straight forward. unscrew old one, install new one. I don't know if thread sealer is used on that one though.

FYI: The motor will sound perfectly fine with no oil until something breaks usually.
 
  #3  
Old 09-06-2009, 03:38 AM
Senior Member
Join Date: Apr 2005
Location: United States
Posts: 859
Default

I agree w/your apprehension to drive it until you are sure the oil pump is working or the screen and/or pick-up is not blocked or clogged. If it's really a gauge and not a dummy light, does it read absolute zero pressure with NO movement at all? Any recent work to the engine? Oil change? What size engine does it have and what is the mileage?
 
  #4  
Old 09-07-2009, 02:51 PM
Junior Member
Thread Starter
Join Date: Sep 2009
Posts: 3
Default

thx for responnding back

well i tried changing the oil b4 anything else (i drove it 2 or 3 months then parked it for like 9 months, so it sat awahile) and now my gauge is reading jus fine...
so apparently it only needed new oil and filter, but while I was changing that I found that the lil pipe that the filter screws onto is lose and it comes all the way out!.
so idk if that was causing the reading or not imma have to check the filter every once in awhile to make sure its not loose...
idk if that pipe is suppose to come out or not, but i have an oil leak apparently and now I gotta find out where its coming from, not sure if its cuz of the filter not being on tight or not bottom of engine filthy....
so hopefully i'll get that cleaned up and be able to find out whats going on...
 

Last edited by bittersweetiris; 09-07-2009 at 02:55 PM.
  #5  
Old 09-07-2009, 02:54 PM
Junior Member
Thread Starter
Join Date: Sep 2009
Posts: 3
Default

Originally Posted by conan312 View Post
I agree w/your apprehension to drive it until you are sure the oil pump is working or the screen and/or pick-up is not blocked or clogged. If it's really a gauge and not a dummy light, does it read absolute zero pressure with NO movement at all? Any recent work to the engine? Oil change? What size engine does it have and what is the mileage?
no the gauge moved, but most of the time it would stay low and my "check gauges" light would come on.....
I have had the car 4 yrs and have had no probs except for the egr valve (which replaced) and a lil sensor on the trans (which was replaced) cuz my speedometer was messing up...
is a v8 4.6
but now it seems to feel like its switching gears hard, im kinda not really sure but i'll hit the gas and take my foot off and it like hits hard..i havent driven in in awhile but I dont member it doing that b4.

and i just turned over 152,000 miles
 
  #6  
Old 02-18-2014, 08:37 AM
Junior Member
Join Date: Feb 2014
Location: St. joseph, mo.
Posts: 11
Default

i have a 95 also bro... will be looking for this problem in the future...
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MercuryWQQ
Sable
3
05-05-2009 04:30 PM
Aarons Merc
Milan
6
09-05-2008 08:56 AM
SEFH
Mountaineer
0
11-20-2006 09:55 AM
steve
Mountaineer
8
01-20-2006 12:01 AM


Thread Tools
Search this Thread
Quick Reply: 95 cougar no oil pressure...


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.