General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

2005 Montego Error Messages and gauge problem

  #1  
Old 05-12-2012, 05:50 AM
Junior Member
Thread Starter
Join Date: May 2012
Posts: 1
Default 2005 Montego Error Messages and gauge problem

I have a 2005 Mercury Montego that is showing error messages on the instrument cluster, fuel flow error and an odometer data error, the tach and speedo is not registering when driving, the check engine light, battery light and ABS lights are all lit and the car will not communicate with my scan tool. Car will run but needs to crank over a little longer to start now, tried cleaning the battery terminals thinking maybe it is a grounding issue, dealer has changed out the instrument cluster before, car is awd and has almost 125,000. I am really stumped on this one and any help would be greatly appreciated. Thanks
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dobie1966
Grand Marquis
0
09-09-2014 06:30 PM
propav8r
Mystique
0
03-18-2010 05:17 PM
mrscurva
Mountaineer
2
09-18-2009 11:04 AM


Thread Tools
Search this Thread
Quick Reply: 2005 Montego Error Messages and gauge problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.