General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

92 Cougar no heat

  #1  
Old 12-01-2005, 11:22 AM
Junior Member
Thread Starter
Join Date: Dec 2005
Location: United States
Posts: 3
Default



My 92 Cougar's heater is not working. All I get is cold even after running for 30 min. I bought a new climate control, but have not installed it yet, just incase its something else. I have heat through the hoses to the firewall, but after that nothing. Ofcourse air works fine. Throw at me what you think I will try it all.





Thanks In Advance
 
  #2  
Old 12-01-2005, 04:55 PM
Administrator
Join Date: Mar 2005
Location: United States
Posts: 172
Default

perhaps a bad heater core? any antifreeze smell in the car? dampness?
 
  #3  
Old 12-01-2005, 05:05 PM
Junior Member
Thread Starter
Join Date: Dec 2005
Location: United States
Posts: 3
Default

No smell of antifreeze in car. Doesn't seem damp.
 
  #4  
Old 12-06-2005, 01:27 PM
Senior Member
Join Date: Oct 2004
Location: United States
Posts: 132
Default

Check vacuum lines to block(vacuum block/manifold,usually behind intake manifold under cowl/firewall area)and regulator. A possible leak to damper door will cause this to happen. Edited by: Lenny
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
denno
General Tech Help
4
05-14-2011 10:23 PM
Jadman
Grand Marquis
14
01-27-2011 07:56 PM
Cheryl
Audio/Visual Electronics
0
02-01-2008 06:09 PM
truckin77
Sable
5
01-28-2008 02:42 PM
Skylane182
General Tech Help
2
12-04-2007 06:41 PM


Thread Tools
Search this Thread
Quick Reply: 92 Cougar no heat


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.