General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

97 Mercury Villager GS shifting problem

  #1  
Old 01-02-2018, 06:59 PM
Junior Member
Thread Starter
Join Date: Jan 2018
Posts: 1
Default 97 Mercury Villager GS shifting problem

I have a 97 villager I bought and for a while it ran fine. The CEL has been on since I got it the code is P0120 for TPS... well as of yesterday the van won't shift from 2nd to 3rd gear while O\D is off, when it shifts it feels like it goes into neutral... When O\D is on you can feel it shift to 3rd but when you hit the gas pedal the van won't even move until the rpms are around 4k. The TPS that is on there is fairly new. Not sure if that's what would cause the shifting to be like that or not.. If anyone has any ideas please let me know..
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
edr1979
General Tech Help
0
12-09-2011 04:51 PM
ClintsCougar
Cougar
1
02-14-2010 10:23 PM
waveoner76
Mountaineer
4
11-24-2009 09:56 AM
mrhaz
Mountaineer
3
09-26-2007 05:52 PM
stephanie80
General Tech Help
4
02-08-2006 02:04 PM


Thread Tools
Search this Thread
Quick Reply: 97 Mercury Villager GS shifting problem


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.