General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

cooling problem

  #1  
Old 10-29-2005, 03:02 AM
Junior Member
Thread Starter
Join Date: Oct 2005
Location: United States
Posts: 1
Default



i have a 97 xr7 the cooling system is spraying coolant every where right behind the water pump. i already replaced the pump and that didnt do it. it looks as though there is water or antifreeze burning in the negine as well cause of the white smoke coming out of the exhaust anyone have any ideas what the hell this problem is please let me know asap thanks.


[img]smileys/smiley5.gif[/img]
 
  #2  
Old 11-01-2005, 04:51 PM
Administrator
Join Date: Mar 2005
Location: United States
Posts: 172
Default

hwo about the intake manifold gasket? did it overheat badly? it may have warped things.
 
  #3  
Old 11-22-2005, 10:59 AM
Senior Member
Join Date: Oct 2004
Location: United States
Posts: 132
Default

Do a compression check. could be head gasket and/or freeze plugs.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
terryeckel
Cougar
0
09-18-2013 01:30 PM
kevin1467
Capri
4
08-17-2008 05:06 PM
Bobbin Jones
Sights N Sounds
1
08-13-2008 05:31 PM
Stray Dogs
Cougar
0
05-19-2006 08:42 AM
Coachkey22
New Member Area
3
03-21-2006 08:49 PM


Thread Tools
Search this Thread
Quick Reply: cooling problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.