General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

Strange Altinator problem:(

  #1  
Old 06-08-2008, 12:59 AM
Junior Member
Thread Starter
Join Date: Jun 2008
Location: Canada
Posts: 3
Default

I Have a 1996 Mercury Sable, and I am having a problem with my altinator kicking out at 2000 RPM. Brushes and regulator are fine. Anyone got any ideas? Thanks.
 
  #2  
Old 06-08-2008, 04:35 PM
Junior Member
Join Date: Jun 2008
Location:
Posts: 3
Default



When you say Kicking Out..just what does than mean our Canadian Friend.


MercuryMan [img]smileys/smiley16.gif[/img]
 
  #3  
Old 06-13-2008, 11:29 AM
Junior Member
Thread Starter
Join Date: Jun 2008
Location: Canada
Posts: 3
Default

The Altinator turns off at 2000RPMs and the viechle starts running off battery power, until the RPMs drop below 2000 again then the Altinator turns back on.The viechle runs fine until the battery dies.
 
  #4  
Old 07-02-2008, 09:56 AM
Junior Member
Join Date: Jun 2008
Location: United States
Posts: 13
Default

try checking the cable from the battery to the alternator. It is a common problem they get cooroded or loosen. That is where I would start first.
 
  #5  
Old 07-05-2008, 02:34 AM
Junior Member
Thread Starter
Join Date: Jun 2008
Location: Canada
Posts: 3
Default

Fixed problem, I did have to change out the entire altinator, no way around it, I guess you could buy a core because the brushes and regulator were still good.
 
  #6  
Old 07-09-2008, 09:39 AM
Senior Member
Join Date: May 2008
Location:
Posts: 455
Default

it was the voltage regulator in the alternator. They can not be changed on these because the parts are not readily available like they use to be in the old days when rebuildable kits were on the market
 
  #7  
Old 12-06-2008, 06:30 AM
Junior Member
Join Date: Nov 2008
Location: Canada
Posts: 15
Default

by what he''''s saying i''''d sat the rotor was bad and a wire was sepperating inside when rpm got higher seen it many times Edited by: ramit98
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mercuryowner1
Sable
0
12-25-2013 07:53 PM
New Mercury Owner
Mystique
5
10-06-2009 04:44 PM
AndrewSmith
Sable
4
07-04-2009 05:22 PM
kbsmom
Villager
5
08-13-2008 06:30 PM
dmddfkc
Mountaineer
0
08-07-2007 10:11 AM


Thread Tools
Search this Thread
Quick Reply: Strange Altinator problem:(


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.