Mariner Discuss the Mercury Mariner here...

05 mariner, 3.0 v6 2wd

  #1  
Old 07-08-2014, 12:32 PM
Junior Member
Thread Starter
Join Date: Jul 2014
Location: Wewoka Oklahoma
Posts: 1
Angry 05 mariner, 3.0 v6 2wd

My mariner is throwing 4 codes, p0405 (dpfe egr sensor) , p0351/0353/0354 (ignition coil a, c, d primary and secondary circuit) the car died driving on the highway, took a bit to start it back, now it idles rough and I can hear a vacuum leak but can't trace it down. First reading showed all 6 coils were bad, reset and ended up with just c, now, I've got three. Horrible gas mileage, very sluggish and at this point it won't go more than 45 mph downhill. Any suggestions? I've replaced all three coils which was expensive and didn't do any good and was told that there's a problem with this year make model frequently showing false readings on the egr. How do I find out if its false and what to do now????
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MOUNTAINEERBILL
New Member Area
1
02-13-2008 02:21 PM
MarinerTX
Headers, Intake, & Exhaust
5
11-10-2005 03:36 PM
MarinerTX
Mariner
2
09-27-2005 08:51 PM
MarinerTX
New Member Area
3
08-25-2005 05:31 PM
MercAdvisor
Mariner
1
08-25-2005 05:12 PM


Thread Tools
Search this Thread
Quick Reply: 05 mariner, 3.0 v6 2wd


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.