Mariner Discuss the Mercury Mariner here...

2006 Mercury Mariner V6 engine noise

  #1  
Old 02-26-2014, 07:14 PM
Junior Member
Thread Starter
Join Date: Feb 2014
Posts: 2
Default 2006 Mercury Mariner V6 engine noise

Its a 2006. owned it since 2007. has 107,000 miles.
No previous problems, was driving yesterday, came to a stop light, stopped. engine shook and shut off. placed it in park, restarted it. runs rough. LOTS of valve train noise. slow throttle response.
Ran the codes. has P0340 and a P2198 code. The P0340 code is the cam position sensor. i Replaced it. no change. The P2198 code is i read is a lean fuel code. (not the problem)
Any and all advice will be greatly appreciated. Thanks
 
  #2  
Old 09-08-2014, 12:27 PM
Junior Member
Join Date: Sep 2014
Posts: 1
Default

I had a similar problem. Started the vehicle and it sounded like something was broken inside the valve cover and was being thrown about. After listening to it more closely I could hear that is more of a misfire instead of something that was broken. Very loud. Engine ran rough and had a hesitation when stepping on the gas pedal and the only code it was returning was P0340.

Turned out that my timing chain jumped due to a chain tensionor that was failing. Replaced the chains and tensionsors and all is well.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bmw372
Mariner
0
03-13-2014 05:35 PM
MarinerTireProblems
General Tech Help
2
11-06-2013 09:11 AM
Siconi
New Member Area
0
10-26-2012 01:26 AM
zapitbullseye
Mariner
0
10-21-2006 07:09 PM
Sarge148
New Member Area
3
04-02-2006 01:20 PM


Thread Tools
Search this Thread
Quick Reply: 2006 Mercury Mariner V6 engine noise


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.