Brake problem help please. - Mercury Forum - Mercury Enthusiasts Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 08-08-2017, 04:34 PM
Junior Member
Thread Starter
 
Join Date: Jun 2015
Posts: 3
Cool Brake problem help please.

I have a 1950 Mercury with stock brake system and master cylinder. My problem is that when shifting into drive the brake pedal drops and the car lurches forward about 10 or 12 inches.

I have had the brakes bled and fluid replaced and brakes adjusted. The pedal is high and firm. The issue above persists. I do not see indication of wheel cylinder leakage on the inside of the tires. If anyone has an answer to this issue it would be much appreciated. Thank you.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help! Please help!! pooldave1 Sable 3 03-13-2013 08:04 PM
brake pedal squeak and brake replacement stangcbr Mountaineer 2 05-15-2010 10:37 PM
Weird problem...Please help!! wolfbiker99 Cougar 16 11-16-2008 05:51 PM
new problem please help jenlegs Sable 5 07-23-2008 06:53 AM
mercuyvillager brake problem dclutter8647 Villager 0 09-30-2007 07:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 05:00 AM.