Monterey Discuss the Mercury Monterey here...

Help with 65 Monterey

  #1  
Old 10-29-2018, 05:24 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 2
Default Help with 65 Monterey

Hello all, I have a 65 Monterey with original 390 motor, here is my problem. Just went out to start the car, it has been sitting couple weeks,turn key,little puff of smoke from battery terminal,clicks one time and nothing. Hook up booster,fires up. Normally after the car has been sitting I do not have to boost it. Here is main problem I have been having for long time. I just took car out for about a 20 minute ride,park it in garage and turn it off. I immediately try to restart the car,turn key,one click then nothing. This has been happening for long time usually when car has been sitting for while it will start but once I take it out for ride then turn it off it will not start again,driving me crazy,any thoughts?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
zombi138
Monterey
2
05-15-2018 08:21 PM
Coatsy
General Tech Help
2
09-02-2012 10:39 PM
surgetek33
Monterey
0
04-12-2011 08:25 PM
jswift
General Tech Help
0
12-09-2010 09:47 AM


Thread Tools
Search this Thread
Quick Reply: Help with 65 Monterey


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.