Go Back  Mercury Forum - Mercury Enthusiasts Forums > Past Productions > Mystique
Reload this Page >

2000 Mercury Mystique - Won't turn over after replacing Fuel Filter

Mystique Discuss the Mercury Mystique here...

2000 Mercury Mystique - Won't turn over after replacing Fuel Filter

  #1  
Old 02-02-2012, 07:30 AM
Junior Member
Thread Starter
Join Date: Feb 2012
Posts: 2
Question 2000 Mercury Mystique - Won't turn over after replacing Fuel Filter

I have a 2000 Mercury Mystique that I changed the fuel filter on. This in itself was a relatively easy procedure. Unfortunately, when I went to start the car up, it didn't want to stay running and idled only when my foot was on the pedal and then stalled out and made a noise in the engine area that sounded like a backfire.

Anyone have any ideas on what the problem is?
 
  #2  
Old 02-10-2012, 03:23 AM
Junior Member
Join Date: Feb 2012
Posts: 2
Default fuel filter

Originally Posted by bluelight320 View Post
I have a 2000 Mercury Mystique that I changed the fuel filter on. This in itself was a relatively easy procedure. Unfortunately, when I went to start the car up, it didn't want to stay running and idled only when my foot was on the pedal and then stalled out and made a noise in the engine area that sounded like a backfire.

Anyone have any ideas on what the problem is?

the first thing that popped into my head is that when you installed the fuel filter you may have put it in backwords they do have to flow a certin way or they get clogged and dont allow enough gas to pass through there for rough idle and stalls out or it may be the wrong fuel filter but most of the timmes it is put in the wrong way
 
  #3  
Old 02-11-2012, 05:53 AM
Junior Member
Thread Starter
Join Date: Feb 2012
Posts: 2
Default

Originally Posted by daveman View Post
the first thing that popped into my head is that when you installed the fuel filter you may have put it in backwords they do have to flow a certin way or they get clogged and dont allow enough gas to pass through there for rough idle and stalls out or it may be the wrong fuel filter but most of the timmes it is put in the wrong way

daveman,

Thanks for the reply. That was my original suspicion but it ended up NOT being the problem. I found the problem to be a vacuum leak and as soon as I found it and rectified the problem by reconnecting the hose, the car started up immediately.
 
  #4  
Old 02-12-2012, 01:43 PM
Junior Member
Join Date: Feb 2012
Posts: 2
Thumbs up fuel filter change

Originally Posted by bluelight320 View Post
daveman,

Thanks for the reply. That was my original suspicion but it ended up NOT being the problem. I found the problem to be a vacuum leak and as soon as I found it and rectified the problem by reconnecting the hose, the car started up immediately.

well that's good to here you were able to resolve the problem
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
murkeree_owner
Grand Marquis
0
03-10-2014 12:00 PM
kolob
Grand Marquis
1
11-03-2012 11:53 PM
Hetron
Grand Marquis
0
03-06-2012 09:36 PM
Momoftwosonsintrouble
New Member Area
2
06-11-2011 09:59 AM
sillyburt
Sable
1
04-16-2007 02:59 AM


Thread Tools
Search this Thread
Quick Reply: 2000 Mercury Mystique - Won't turn over after replacing Fuel Filter


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.