Mystique Discuss the Mercury Mystique here...

Radiator fan issue.

  #1  
Old 04-22-2010, 11:02 PM
Junior Member
Thread Starter
Join Date: Apr 2010
Location: Palmetto, GA
Posts: 3
Default Radiator fan issue.

well i got this car about 3 months ago and just now got around to working on it. its a 98 mystique and for some reason the radiator fan just wont kick on and there seems to be alot of pressure building up somewhere (you can hear alot of hissing and gotta decompress it occasionally to let the pressure out of the reservoir) but my main concern is still fan, the relay is fine i traded it out with the ABS sensor since its the same resistance (100 amp yellow relay if im not mistaken) but still no go, once in a while it will cut on but my overheating issue has been calmed down because i replaced my standard 180F thermostat with a 96 mustang 160F thermostat. if anyone owns one that runs a lil hot it sugest trying that because it reallys makes a difference (even without fans running my thermostat doesnt go above the M before it opens up and cools it down). but anyone have any ideas? i havent check for an open circuit since it stills does turn on and i hope im specific enough. haynes manual just isnt sugesting much
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Milew23
General Tech Help
1
08-15-2014 12:59 PM
FAUSTOCG
Monterey
0
03-15-2013 08:09 PM
greggyc
Grand Marquis
2
01-18-2009 08:38 AM
h0l0caust
Tracer
0
11-08-2006 07:44 PM
Sean K77
Mystique
0
07-18-2006 11:40 PM


Thread Tools
Search this Thread
Quick Reply: Radiator fan issue.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.