Mystique Discuss the Mercury Mystique here...

running hot

  #1  
Old 12-16-2006, 07:03 PM
Junior Member
Thread Starter
Join Date: Dec 2006
Location: United States
Posts: 1
Default

Im stumped, I have a 96 Mystique 2.5liter V6 24 Valve Doch with 82K original miles on it. Heres whats goin on, A few weeks ago i was driveing and all of a sudden the temp gauge went all the way to red and started shakeing, i drove home. The radator light came on and the temp gauge went all the way to red and stayed there, even when i turned the car off and turned it on the next morning. I went and bought a thermastat, installed it, added coolant, still runs hot. When i drive it i noticed after about a half mile of driveing, after reaching operating temp the coolant comes past the max line then starts bubbleing and hissing in the run-off tank, The coolant when the engine is cold goes back to the normal "max" line, but when it gets hot it comes all the way up to the cap and it hisses and steams. Possibly a water pump? I of course dont bring my cars to dealerships so please do not just say bring it to a shop, i just want your input. Thankyou
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dasmin14
Sable
8
06-11-2009 02:45 AM
tinytanic1
Cougar
0
05-27-2008 05:24 PM
FlaSable
Sable
7
11-30-2007 03:53 PM
jmd2914
Sable
1
07-22-2007 10:06 PM
Cephus
Sable
4
09-19-2006 04:02 PM


Thread Tools
Search this Thread
Quick Reply: running hot


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.