Sable Discuss the Mercury Sable here...

1999 Sable LS Rough Idle at Times

  #1  
Old 02-17-2009, 01:31 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Location: United States
Posts: 5
Default

I''m new here and looking for some advice. I just bought a 1999 Sable LS with the Duratec engine. I have noticed that at certain times, not all the time, when I am stopped at a light the car begins to idle rough. Also, when I start to accelerate, i get some hesitation. Like I said it is not all the time, but it does happen more than I care for it to.
I have checked the air filter and it appears clean. I also added Slick 50 fuel system cleaner. The only thing I have not checked yet is the fuel filter.
Does anyone have any ideas on what this may be?
Thanks

 
  #2  
Old 02-17-2009, 02:07 PM
Senior Member
Join Date: Nov 2008
Location: United States
Posts: 232
Default



Vacuum leaks can cause this sort of thing as well as a dirty Idle Air control valve... Fuel filter would probably be a good place to start, they''re cheap and it probably is due for one anyhow if you don;t know when it''s been changed last....There were also some issue with the mass airflow sensor but these will USUALLY set off the check engine light...


Now to blast you with questions. How many miles does it have? Has it been tuned up ever? IS the check engine light on?
 
  #3  
Old 02-17-2009, 02:25 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Location: United States
Posts: 5
Default

Max, thanks for the fast reply. As a matter of fact, the "service engine soon'' light just came on today. What can this be for?
The car has 106K miles.

 
  #4  
Old 02-17-2009, 03:41 PM
Senior Member
Join Date: Nov 2008
Location: United States
Posts: 232
Default



You''''ll have to have acode reader or scan toolto get the trouble codes to see why the light is on... Autozone and Advance used to do this for free..Or there are some inexpensive code readers out there in the $50 range (Probably about what most shops will charge to do this)... These will work on all 1996 and newer cars... It would probably be best to start with why the light is on... It could be any number of things that may or may not be related to your problem....


Manufacturer usually specifies for a tune up around 100K.. Tune up consists of at least new spark plugs, wires, fuel and air filter.. Some makes/models have other things to be done (egr or Idle air motor cleaned) but that''''s the basic...Edited by: maxfax3
 
  #5  
Old 02-17-2009, 03:47 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Location: United States
Posts: 5
Default

Where can I see the trouble codes? Where on the car do I pull this from?
 
  #6  
Old 02-17-2009, 05:40 PM
Senior Member
Join Date: Nov 2008
Location: United States
Posts: 232
Default



There is a diagnostic connector under the dash on the driver''s side to the left of the steering column.. That is where you''ll have to connect an OBDII code reader or scan tool...
 
  #7  
Old 02-17-2009, 07:00 PM
Senior Member
Join Date: Oct 2008
Location: United States
Posts: 1,361
Default

you can also have a parts place read the codes for you. I know autozone will read 1996 and newer OBD-II vehicles (which yours is) for free.
 
  #8  
Old 02-18-2009, 01:47 AM
Junior Member
Join Date: Feb 2009
Location: United States
Posts: 3
Default

I have the same sable as u, 99 ls.
Mine does the same thing, hesitates after accelerating from a stop, or randomly while driving low speeds. I was wondering the same thing as you. Let me know what it turns out to be for you.


 
  #9  
Old 02-18-2009, 03:28 PM
Senior Member
Join Date: Oct 2008
Location: United States
Posts: 1,361
Default

It may need new plugs as well. I think my MGM is finally in need of new plugs. maybe even a top end tune up. I have just over 105k miles on it.

top end tuen up usually consists of plugs/wires/rotor/distributor cap/coil/capacitor (pick the parts that apply to your vehicle) and sometimes Oxygen sensors and the intake air flow sensors.

I think I''ll check mine this weekend since the weather looks like it will cooperate.
 
  #10  
Old 02-23-2009, 03:02 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Location: United States
Posts: 5
Default

I brought the car into Autozone and had them check the engine light. The guy told me it was for a misfire in piston #2. He said it could be a bad plug or a dirty plug. Advised me to add some of the new concentrated gumout fuel injector cleaner and add fill up with 93 octane. Give 2-3 days and should be fine. I did what he said and I am on day 3 and the car is still the same. BTW - I noticed when I gun it, right before it kicks in I hear a "click" noise or a "knock" that sounds like it is from the engine. Then the car speeds up.
Any help is appreciated

 

Thread Tools
Search this Thread
Quick Reply: 1999 Sable LS Rough Idle at Times


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.