Sable Discuss the Mercury Sable here...

Rear window/outside mirror defrost

  #1  
Old 02-21-2009, 07:44 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Location: United States
Posts: 7
Default



My 2003 Sable''''''''s rear window defrost & outside mirror defrost are not working.


1. The light is turned on once the defrost switch on the IP is pressed.


2. I canhear the clicking noise from the relay on the dash when the defrost swith is pressed.


3. All the relays and fuses are checked and they are fine. The grid on the rear window is also checked and they are all connected well.


Now what? Why is this kind of mulfunction happening to a poor guy like me?[img]smileys/smiley19.gif[/img]Edited by: koen
 
  #2  
Old 02-21-2009, 08:22 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Location: United States
Posts: 7
Default



I just found the connecting part (tab) on the left side of the rear window is detached from the window. Can I just glue it with some conductive glue?


1. Is it possible that my outside mirror defrosting is not working because of the detached connection on the rear window?


2. Has anyone attached this using a quick fix repair kit, not a soldering fix? I heard soldering might break the glass.Edited by: koen
 
  #3  
Old 02-22-2009, 02:52 PM
Senior Member
Join Date: Nov 2008
Location: United States
Posts: 232
Default



IT is possible the broken connection at the window is keeping everything from powering on... Some of the rear defrost timers rely on a certain amp draw.. IF it isn;t there at all or there is too much it will not kick on..


The regular conductive glue would probably be your best bet to re attach the terminal on the window.. I''ve had mixed results with the stuff (sometimes it lets loose in hot weather) But definitely don;t try the solder the thing.. The window will go pop real quick like... IF you have a test light see if you get power to one of the terminals to the rear window..
 
  #4  
Old 02-23-2009, 06:34 PM
Senior Member
Join Date: Apr 2005
Location: United States
Posts: 859
Default

I agree w/the non-solder method. As for the heated rear mirrors, mine are always operating. I think they are heated year round at a low temp cause I know mine work without the rear defroster on. Even does away with early morning summmer dew. Then again mine is a ''97. Did they stop working at the same time?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
HLT
Grand Marquis
1
05-01-2009 08:30 AM
rcupak
Mountaineer
4
03-22-2009 03:59 PM
89marq
General Tech Help
1
01-17-2008 05:48 PM
sargej1
Grand Marquis
1
03-30-2007 07:27 PM
bvkirk
Mariner
0
08-23-2006 11:28 PM


Thread Tools
Search this Thread
Quick Reply: Rear window/outside mirror defrost


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.