General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

2005 mercury marquis

  #1  
Old 04-18-2012, 06:20 PM
Junior Member
Thread Starter
Join Date: Apr 2012
Posts: 1
Default 2005 mercury marquis

I had a bad lcm. No headlights for a year, just high beams. Rude I know. Couldn,t afford to replace it, not at between 600 @ 900 dollars. Finally sent for a rebuilt module. Module Repair Pro, Inc, L.A. Ca 90019. So far so good, everything works. Some controversy about the box being programmed by a Ford dealer. Some say it won't work with out that, some say it's free standing. The Module Repair people said they all ready did that. Just plug it in. For me, it worked. Some instructions say you have to remove the gas pedal to get to the box. I have adjustable pedals. I didn't do that, what I did was bend the cradle for the box so I could get it out. It worked. I also had a bad pulley on the serpentine belt tension arm. Caused all kinds of problems. Check engine light, rough idle, transmission shifted rough, car on the verge of a stall at a light. Changed the pulley and all that went away, check engine light went out. When I checked the engine light code, it said. Throttle plate bad, vacuum leak, etc.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mariner
1
04-07-2015 12:20 AM
Janice Belisle
New Member Area
1
02-22-2014 09:45 PM
ronkur
Mariner
1
03-24-2013 07:34 PM
RogerB
Mountaineer
0
06-24-2011 09:43 PM
varnold
News, Updates & Announcements
3
03-20-2009 07:28 PM


Thread Tools
Search this Thread
Quick Reply: 2005 mercury marquis


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.