Mystique Discuss the Mercury Mystique here...

I need help!!!

  #1  
Old 09-02-2007, 08:12 AM
Junior Member
Thread Starter
Join Date: Sep 2007
Location: Canada
Posts: 1
Default


<DIV class=Kona X5jix="true" rK9l8="0" P9qKd="0">I just bought this car its a 2.0 with about 175000km on it... when I start the car it seems like its going to stahl... when its idling the rpms go up and down from about 750-1300 or so... if I give it some gas when idling it seems to fix that problem for a bit... when I stoped at a light or stop sign I get a bad rattle in the front passenger side... seems like that side anyways... on the highway when im doing any speed for a long period of time the speed decelerates by itself even if I hammer on the gas there is nothing I can do losing lots of speed... I found if i put it in neutral and rev it up a few times then i put it back in drive i can get up in speed again... I am wondering what is causing these problems if you can help in any way... I know its hard to troubleshoot something on the internet... thanks for your help!</DIV>
 
  #2  
Old 01-18-2008, 02:43 PM
Super Moderator
Join Date: Jan 2008
Location: United States
Posts: 543
Default

have you ever changed the fuel filter on the car?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
troycowanmp
Tracer
0
08-16-2012 10:00 PM
flavor4real
Mountaineer
2
10-03-2007 10:28 AM
mybeast87
Grand Marquis
8
07-30-2006 08:30 PM
amanda129
Grand Marquis
1
03-08-2005 10:57 PM
Higgy
New Member Area
1
02-06-2005 03:13 AM


Thread Tools
Search this Thread
Quick Reply: I need help!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.