Sable Discuss the Mercury Sable here...

Check engine light

  #1  
Old 02-03-2013, 09:32 AM
Junior Member
Thread Starter
Join Date: Feb 2013
Posts: 1
Default Check engine light

Have a 97 sable,70k miles,check engine light on, all four codes,p0135, p0141, po155, po161,heated o2 sensors, performed tsb reprograming pcm, lasted about 1500 miles, codes came back on, no driveablity issues, cleared codes, came back on after second engine cycle, it would be extremely unusual to have all four o2 sensors to go bad at the same on, possible PCM??????
 
  #2  
Old 02-25-2013, 07:33 PM
Member
Join Date: Dec 2012
Posts: 34
Default

Check your fuses/relays (The power distribution box located in the engine compartment near the battery), wiring to the O2 sensors- you can try tracing wiring, wiggling harnesses, and voltage/resistance measurements for faults, if you have power to the sensors it sounds like the PCM/Computer is not energizing the heater circuits , therefore you are simultaneously getting these code readouts. The PCM's have been known for various problems internally(cold solder joints, parts). I would look around for a used one.
 

Last edited by EddieE; 02-25-2013 at 08:13 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
214shaft
Grand Marquis
1
01-03-2011 11:21 PM
sinned1
Sable
8
10-08-2007 01:30 PM
damercga
Grand Marquis
1
12-31-2006 05:24 PM
hdfoor
Sable
6
04-29-2005 10:57 PM
Chris
Sable
1
04-24-2005 01:39 PM


Thread Tools
Search this Thread
Quick Reply: Check engine light


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.