Villager Discuss the Mercury Villager here...

99 Villager Estate

  #1  
Old 01-09-2008, 07:39 PM
Junior Member
Thread Starter
Join Date: Jan 2008
Location: United States
Posts: 2
Default




< src="http://www.google-analytics.com/urchin.js" =text/>
</>
Hey all.. I hope someone can help!! I have a few questions. I am new to the Villager world (from the Aerostar world).. and I have a gas pedal that for lack of a better word "sticks" when trying to accelerate.. it causes the tires to squeal.. but only does so sometimes... any ideas? I also have a pretty rough idle but only in park.. and I think the exhaust smells too much like gas.. I dont' drive it much.. but I have about 80 miles and inbetween 1/2 and 3/4 tank of gas.. is that normal?? No engine light..



Thanks!
< =text/>
_uacct = "UA-939292-45";
urchinTracker();
</>
 
  #2  
Old 01-15-2008, 10:28 PM
Junior Member
Join Date: Jan 2008
Location: United States
Posts: 2
Default




< src="http://www.google-analytics.com/urchin.js" =text/>
</>
Hey, I had that same problem on my 2000 (69,000 mi) Villager.


I had the Throttle Body cleaned, (it can be a DIY, but I didnt have the time) and now it runs SMOOTH... I hope this helps.


U.V.
< =text/>
_uacct = "UA-939292-45";
urchinTracker();
</>
 
  #3  
Old 01-18-2008, 12:38 PM
Junior Member
Thread Starter
Join Date: Jan 2008
Location: United States
Posts: 2
Default


< src="http://www.google-analytics.com/urchin.js" =text/>
</>
Great news!! I cleaned the throttle body myself.. and no sticking!! Anyone know of brake issues?? When it's wet out... the pedal sometimes goes to the floor like the abs is working.. but it's not the ABS for sure.. I know that feeling.. is the master cylinder on it's way out?

< =text/>
_uacct = "UA-939292-45";
urchinTracker();
</>
 
  #4  
Old 01-18-2008, 12:42 PM
Super Moderator
Join Date: Jan 2008
Location: United States
Posts: 543
Default

i would look to see how your brakes look. you might have to adjust the back brakes or get new hardware. have you tried to bleed them out to see if that helps also? i would start easiest by looking the brakes over and see how it looks.
 
  #5  
Old 10-22-2008, 12:11 AM
Junior Member
Join Date: Oct 2008
Location: United States
Posts: 1
Default

When I owned my 99 villager, the accelerator petal sticking I had and sprayed some penetrating lubricant spray in the cable, the rough idling the computer says cylinder misfire, all I did was gave the van a tune up total cost of tune up for me was 125.00. </font>
</span></font>
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dhar
Off Topic
0
02-06-2014 09:34 AM
jerliz
Off Topic
0
12-06-2013 10:51 AM
wafa
Off Topic
0
10-13-2013 09:55 PM
pasole
General Tech Help
1
03-07-2009 01:36 AM
jpmctd
General Tech Help
1
02-24-2009 10:38 AM


Thread Tools
Search this Thread
Quick Reply: 99 Villager Estate


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.