Villager Discuss the Mercury Villager here...

Heating

  #1  
Old 12-06-2005, 10:11 PM
Junior Member
Thread Starter
Join Date: Dec 2005
Location: United States
Posts: 1
Default



I have problem with my 99 Villager heat. It blows cold air while idling or on low speeds. Once speed reaches above 35MPH then the air heats up. It seem that even when adjusting the temp dial, it stays real hot. any one experience this before?
 
  #2  
Old 12-07-2005, 10:41 AM
Senior Member
Join Date: Oct 2004
Location: United States
Posts: 132
Default

check the a/c- heater regulator and damper door for movement.Edited by: Lenny
 
  #3  
Old 01-18-2006, 01:43 AM
Junior Member
Join Date: Jan 2006
Location: Mexico
Posts: 4
Default

Your problem could be due to low coolant level. Check the level of
coolant in the system; eliminate this possibility first because it's
the quickest and easiest.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
itwasntme
General Tech Help
0
10-18-2012 03:48 PM
NH_USA
Sable
1
11-15-2010 08:49 PM
Christian90
Cougar
1
12-04-2008 10:03 PM
ANAG
Cougar
2
11-24-2008 12:42 AM
pdman
Grand Marquis
14
10-21-2008 05:17 PM


Thread Tools
Search this Thread
Quick Reply: Heating


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.