Villager Discuss the Mercury Villager here...

Hoping that someone can help me...

  #1  
Old 04-26-2012, 06:48 PM
Junior Member
Thread Starter
Join Date: Apr 2012
Posts: 1
Default Hoping that someone can help me...

I have recently purchased a used 2001 Mercury Villager and I am in the process of doing some heavy cleaning and replacing parts that need replacing. I noticed that the map lights on the overhead console do not work so I pulled the bulbs and they look ok, I went ahead and ordered new LED bulbs to put in there, but I decided to check the voltage on the connectors and there is no voltage on either side. All other inside lights work, such as the one by the gas pedal, the middle overhead light and the hatch light, but the map lights have no power. Where would I start looking to diagnose the power problem? I have also already checked every fuse in the fuse panel and in the engine compartment and replaced as needed. Any help would be greatly appreciated.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jose
Cougar
3
02-28-2011 10:49 PM
kissy
Grand Marquis
3
07-03-2009 10:17 PM
AndrewMack
Sable
5
03-10-2009 05:56 PM
byran
Mystique
5
06-10-2008 08:38 PM
navybass
Villager
1
07-10-2007 06:53 AM


Thread Tools
Search this Thread
Quick Reply: Hoping that someone can help me...


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.