Mountaineer Discuss the Mercury Mountaineer here...

Transmission help please!?

  #1  
Old 03-03-2014, 08:59 AM
Junior Member
Thread Starter
Join Date: Mar 2014
Posts: 1
Default Transmission help please!?

When I started my 03 Mountaineer this morning (-15 f) there was immediately a 'bang' noise. Everything else was fine, engine was running and I thought it was my coffee mug that wasn't sitting right and fell into place in the cup holder (i.e. not loud noise). I let the car run for a minute and backed out 15 feet or so. When I shifted to Drive there was a horrible gurgling noise and the car wouldn't move.

I quickly shifted to Neutral and shut off the engine. I pushed it out of the way and there is a puddle of tranny fluid (I think, redish brown fluid coming off the bottom of a fluid pan in the middle under about the front seats area).

I found a small shaft 3 inches or so in length that is hollow down the center that is wide on one end and then cuts down to a thin shaft that looks like it broke off on one end.

I can't be without a car right now, and can't afford much but my local ford dealership is backed up till at least Thursday. HELP?!?!!!!

Transmission help please!?-cam01273.jpg

Transmission help please!?-cam01274.jpg
 

Last edited by 03 Mountaineer; 03-03-2014 at 09:00 AM. Reason: formatting....
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
chap110
General Tech Help
2
04-02-2019 12:00 PM
pooldave1
Sable
3
03-13-2013 08:04 PM
rjr162
Sable
0
05-25-2011 09:44 PM
atomheartmother
Sable
0
03-21-2010 11:17 PM
tmcclure06
Tracer
2
04-07-2009 12:06 AM


Thread Tools
Search this Thread
Quick Reply: Transmission help please!?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.